Why isn't this edit allowed?


#1

Pre-existing road:

Road I want to submit:

I get “Couldn’t update the road: Error: road can’t get easier in akrasia horizon”. Why isn’t this allowed? The date for the added segment is outside the akrasia horizon (and just in case it was a fencepost error I tried making it 2018-01-18 more too) and the rate is higher than my current weekly rate (at least according to the statistics tab). The visual road editor also doesn’t warn me about this road, but trying to submit it through that doesn’t work either (presumably the API rejects it for the same reason).

I’ve tried making my lane width 0, 0.01, and 10000 in case it somehow had something to do with lane widths, but it still gets rejected regardless.


#2

Thanks for the bug report, @kenoubi! So as possible workaround and/or debugging help, what happens if you try that at http://road.glitch.me?


#3

@dreev Sorry, that’s what I meant by “the visual road editor”. It doesn’t disable the submit button, but even after submitting it isn’t actually saved to the road.


#4

Ah, yes, sorry. I see it must be at the API level. I’ve successfully reproduced this and need @saranli and @bee’s help but will update you here as we try to figure it out. http://dreev.commits.to/update_kenoubi_re_road_editor/by/jan_18


#5

PS: And have us fix it manually in the meantime by emailing support@beeminder.com (please never feel bad about asking for that, especially when it’s due to a bug like this – that makes it a highly valuable test case for debugging!)


#6

Don’t worry, I’d have emailed support long ago if it were urgent. More interested in leaving this around as a test case (and/or hall-of-shame entry re: Feature Bounty: yellow brick halfplane, which this seems related to).


#7

We think we fixed this! http://beeminder.com/changelog#2535


#8

I can confirm that an analogous edit was just allowed.