Confused by whittle down

Hi folks.

I was trying to make a whittle down goal work for me today, and wasn’t having any luck.

I have a few goals that have a non-zero limit, with basically a 0 rate. For instance, my gmail inbox read count. I have that set to 10, I keep it under 10, wooo.

I wrote a script to get the age of the oldest item in my RTM inbox, and want to beemind that. Currently, this value is ~160 hours.

I made a new whittle down goal, set it with an initial value of 300 so I’d have a good amount of leeway, and everything looks fine. Rate of 0, value of 300, good.

My script fires, adds the data point of 160, and it looks like the graph immediately retroratchets to 160. I can delete the point, and it goes back to 300. I was expecting it to stay at 300.

Just to make sure it wasn’t my script, I deleted the whole goal, actually, and then stopped using the script, and did it by hand, and it was similar.

Should I be using a different goal type? Is it expected that a whittle down goal will throw away the safety buffer like that?

Thanks, folks!

1 Like

I think I encountered the same thing a couple of times… and if it is indeed the same problem, I solved it by making this “initial leeway point” on a different day than the day when actual datapoints start.
I think this might be because of the “minimal” aggday on whittle-down goals.


As @scarabaea says, you may have collided with some magical behaviour that occurs at the start of a goal. It’s trying to decide where the road should start, based on the first day’s aggregated value.

I’ve certainly benefited from this magic on past goals when it did the ‘right thing’ and avoided an instaderail when I edited the initial datapoint.

Magic is maybe great for beginners but stands in the way of more sophisticated users. Complicates the mental model and adds an abundance of edge cases.


Here’s how it worked in practice:

I was a little confused, and deleted the goal, and put in “I am confused by
whittle down–it appears to be autoretroratcheting on datapoints. I will
be recreating to do some tests.”. A little bit later, I get an email from
support saying, “Whittle down? Yup, I can lock that datapoint in for you
if you want.” I responded yes, it got locked in, and everything is great.

Adam Wolf