Beeminder Forum

Integery status recalculation issues - use new "precision" setting.

I just noticed that UVI link to https://blog.beeminder.com/integers/ that mentions new “precision” setting. Not sure is it also gated behind Bee Plus subscription level.

Now report below is mostly outdated.


Recent UVI is

Goals default to integery until you enter a datapoint that’s not a whole number

This is an excellent usability feature for new users, probably worth losing some Bee Plus payments.

But effects were a bit irritating to me:

  • my goal was affected by nonintiger values (as it was something like 5/week)
  • so I switched it to 7/week and added 0.431 datapoint to integerify it manually
  • now, this UVI noticed 0.431 datapoint so it ended as nonintiger
  • this UVI also removed option to integerify goal manually
  • today I had something like +1.0001 required
  • editing old 0.431 datapoint to 1 is not making it integerified, now I have +0.431
  • adding 0.431 datapoint gets me back to +1 point tomorrow, but thanks to floating point magic +1.0001 will return sooner or later and I have no option to force integerification
  • adding -1 to balance my meddling gives me nice +1 today, but sooner or later I will probably get floating point

In my case I am perfectly fine with recreating the goal, I am posting it mostly to help other potentially confused people with suddenly not integer goals.

And maybe editing/deleting datapoint should retrrigger “is it integerified goal” calculation? It seems that any noninteger value permanently taints the goal.

(also, I am additionally unlucky - I just selected this month to go through all my goals to integerify them)

Hi!

You can control how many decimal points are shown by heading to the “Settings” tab under the goal, scrolling down to “Data”, and Changing the “Display Precision” setting. If you want it to have no decimals, like it was when the goal was integery, change that to 1. No goal recreation required!

We’ll need to find a way to make that more clear so that people can find it easily! Thanks for pointing that out!

Maybe put note

this setting is now more powerful and called “precision”, you can find it higher in this page

where this setting used to be? I initially thought that I spotted a bug or that I trashed my goal somehow.

This seems like a bug. This is not happening to any of my goals (I have something like 50 integery ones.).

1 Like