Beeminder Forum

Issues with URL Minder pulling incomplete word count from Google Doc

Before I delete goal attempts 2 & 3, has anyone else encountered (and solved?) the issue of URL Minder not pulling the complete word count from their Google doc? I have a ~28k doc and it’s only counting ~4K.

I read up on this and thought it might be a plain text issue, despite an update (to a blog post?) that said forcing plain text had been automated. I do use headers to separate chapters in the document and that’s way too important and useful for me (for navigating through the document using the outline) to remove them just to (possibly…) get this goal to work properly. I googled around a bit further and found a Trello card marked done from a while back that seemed to say that adding this string of code to the end of URL would force plain text: s/\?dl=0/\?raw=1/. I tried it (hence goal 3…) and it seems to make zero difference.

Anyone with insight on this before I delete and stop wasting hours trying to set up and troubleshoot these things? As a Newbee, I’m finding there’s a real productivity trade-off (opportunity cost of investment) to getting goals set up right.

1 Like

First thing to check: Are you sure you’ve created a “share with link” link or whatever Google Docs calls it? Like the URL you’re giving Beeminder, if you load that in an incognito window, do you see your document?

I think Google Docs recently made this more opaque and we have it on our list to clarify in the UI or give an informative error. That will definitely be great to learn if this is what’s going wrong for you!

PS: Can’t believe you found that old Trello board. We haven’t used Trello for Beeminder development in years! :joy:

1 Like

For the sake of clearing up confusion: what that expression means is "substitute ?raw=1 in place of ?dl=0. In general s/abc/xyz/ should be read as "replace abc with xyz". (It’s a notation that originally comes from ed and its descendants (ex, vi, sed, etc) but has by now come into general use as a shorthand to specify text substitutions in any context.)

(Oh, and don’t be too confused by the backslashes: they’re there in order to say that the ?s should be treated as literal question marks, as opposed to having their regex-based meaning.)

This should clear up the confusion. I don’t know if this will actually solve the word-counting problem, but at least you can try doing that substitution properly and see if that works.

2 Likes

Hi lunagoddess! I’m one of the folks who works on Beeminder itself. I don’t personally use urlminder, and I haven’t worked on it, so I don’t have a quick answer at the moment. However, I know that one of the founders, dreev, uses it regularly.

Also, while this is not as satisfying as an answer, I can assure you user confusion posts and emails are taken very seriously! They drive a lot of what gets worked on day-to-day by the team.

2 Likes

Yay! That tip helped, @dreev! The link I’d copied required log-in when I tested it :woman_facepalming:

I re-shared using the ‘sharing’ path instead of the ‘copy link’ path per the images and it worked like a charm :ok_hand:

Nothing like seeing your safe days jump to ~a year lol… now to ratchet that away!



Pre-testing your link would be a good step to add to the help documents or some future goal-setup-wizard for mobile, if such an interface is in the cards one of these days.

2 Likes

Thanks, @zzq - I appreciate the insight on the coding. Turns out adding that string was a bit of a red herring in the end and it was a PEBCAK error, but pointing to the right URL (and testing said URL :crazy_face:) fixed it right up :slight_smile:

2 Likes