Beeminder Forum

GitHub integration broken?


#1

I’m trying to add a goal using the GitHub integration. These are the settings I’m using:

Hitting “Connect to GitHub” results in a flash of the blue bar at the top of the page, followed by nothing, in both Chrome and Firefox Developer Edition.

Hitting the button results in this error in the Chrome console:

application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:9190 Uncaught TypeError: Cannot read property ‘indexOf’ of undefined
at Object.success (application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:9190)
at f (application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:2)
at Object.fireWith [as resolveWith] (application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:2)
at r (application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:4)
at XMLHttpRequest.r (application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:4)

In Firefox, the errors are different and seem to be related to Firefox’ new content blocking feature:

Request to access cookie or storage on “https://www.facebook.com/tr/” was blocked because it came from a tracker and content blocking is enabled. new

TypeError: data.repos is undefined[Learn More] application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:9190:9
validateForm https://www.beeminder.com/assets/application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:9190
f https://www.beeminder.com/assets/application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:2
fireWith https://www.beeminder.com/assets/application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:2
r https://www.beeminder.com/assets/application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:4
r https://www.beeminder.com/assets/application-4aeadbaed4bfb314986685c631be6351cb960e879049c5d3249c0cbdaee774d1.js:4

Turning off content blocking for Beeminder eliminates the first error, but the second error still occurs.


#2

I don’t know if this is relevant but the repository I’m trying to watch is a private repo; though, it doesn’t seem like this should be a problem since I expect that clicking “Connect to GitHub” is supposed to give me the opportunity to grant Beeminder access to all my repositories.


#3

Howdy, I haven’t gotten a chance to take a look at what’s going wrong in goal creation, but I did have someone report problems with github auth during goal creation recently and say that the auth step worked fine if they visited beeminder.com/services and authed from there, then went and created the github goal with no need for an auth step (since they’d already granted us permission).


Narthur's Beeminder Journal
#4

This worked! Thank you :slight_smile: