Debugging Github integration

Hey there, bees!

I’ve created a goal using your github integration, but am not seeing any progress yet. (I’ve pushed 3 commits to the master branch since starting my goal. One commit yesterday and two of them since the night rolled over into the “next day”.)

I’ve tried hitting the refresh button a couple of times and went looking in the settings for the private repo name I used, but I can’t seem to find that.

So my question is really: What can I do to debug this? I might have entered the wrong repo name…

Thanks & enjoy!

1 Like

Hey, I’ve dug into the api output from Github and I’m getting blank responses – no errors, just no results for the repo. I thought it might possibly have been a typo in the repo name so I made another query to verify the name of the repo, and saw you’ve got another similarly named repo, but no commits are returned for either repo. Can you check the permissions granted to the beeminder app here: (in particular that we’ve got access to private repos)?



Thanks for the response during the weekend. :smile:

Hmmm… the Github permissions look like they’re set up correctly:

Green ticks next to both “Access private repositories” and “Update all user data”.

It’s strange that you’re getting empty API responses, though.


Hey Ranier, so it looks like we did find 1 commit on master for today. I checked as far back as two weeks ago and see no other commits on the master branch of your repo rdrey/teachify – does this sound sane? Is rdrey/teachify the repo that you wanted to track? were the three commits made by the github user you authed Beeminder with (rdrey) ?


1 Like

Hey Bethany

I think I just figured out the issue. (I can’t upload pictures yet) I spotted that the “pulse” tab on my repo had 3 contributors - a buddy and my account twice.

Excluding merges, 3 authors have pushed 10 commits to master and 10 commits to all branches.

The one commit that Beeminder picked up was from and the other ones that weren’t picked up were from my work computer’s git config:

➜  teachifyMe git:(master) ✗ git config -l | grep user Dreyer

I guess that setting my email will cause the github API to report my commits correctly.

Thanks a lot!


Yeah, I can confirm that it works now. :smile: Thanks a lot, my bad!