[Solved] Cannot create new Github goal to track private repo

Dear Beeminders

I cannot seem to create a new goal to track a private Github repository.
When I feel https://www.beeminder.com/new#github to point to a private github repo of mine, click on “Connect to Github”, I then see very briefly a “Checking for that repository” blue banner that flashes (< 1 second), then nothing, I still just see the form. I do not get any request to allow Beeminder on Github [which I never did before].

Am I missing a step? Or is there a bug for private repos?

Below are the settings – the repo “jucor/one_private_repo” is a private repo I created precisely for this post.

Thanks for any help! Happy to try any things to help any debugging, grant access to the repo, etc.



You could try to message the support. They’re very helpful and it’s probably easiest for them to confirm if this is indeed a bug, or not.

1 Like

Thanks @matti, I’ll try that. I was under the impression that the support was only if one didn’t want to use the forum, as per the contact page which states:

If you don’t feel like participating in our user forum, you can email support@beeminder.com

I’ll email them right away.


Problem solved thanks to Chelsean and @bee’s great support! For some reason the OAuth was not triggered automatically, but adding Github by clicking in Beeminder’s settings page solved everything. All is well now :slight_smile: