iOS Shortcut Integration

I noticed that the latest version of the Beeminder iOS app had support for Shortcuts, but when I tried to use the Add Data action I got a “Could not run Add Data - There was a problem communicating with the app”.

Is it me doing something wrong or the app? I was just trying to add a “1” datapoint to a newly setup goal (also tried with an old goal, same problem). I can’t see anything that needs configuring anywhere.



I’ve had the same issue - haven’t been able to use the Shortcuts integration yet. I’ve tried restarting the Shortcuts app, the Beeminder app, and my phone.


I have had the same issue (also emailed a bug report to @dreev).


Me too. Thanks everyone for reporting this.

Apparently it’s harder to get working than anyone might expect. It works for @apb himself, and he’s busily trying to figure out what’s going wrong for many of the rest of us.


I’m also having this problem. Please let me know if there’s any logs or similar I can share.

ADDENDUM: my device has a corporate management policy.

1 Like