Bug?: Weight logging through UP

I recently started a weight loss goal which pulls the weight data from the UP app.

There are a couple of things that are bugging me.

  1. Only one data point per day seems to be logged. Logging for more than once a day picks up the latest logged point.
  2. Timestamp (Date?) for each data point seems to be incorrect. This could be timezone problem. I’m in UTC+10 and when I log weight in the morning, the data point is logged for the previous day (overwriting the previous day’s point due to 1. above).

Hey there, just to double check, looking at your goals now you’ve got a fitbit weight goal, but no jawbone goals. Did you since give up on beeminding weight with jawbone and delete the goal? or was that a mis-speak and I should be looking at the fitbit code to debug here? :slight_smile:

1 Like

Hey @bee , I broke my UP and figured I’d get a fitbit with HR and hence the migration.
I’ve tried to link jawbone and Beeminder through a custom script and discovered that the issue is that UP doesn’t have any timezone. You might be using the ‘date’ field from body event api [1]. Although the app does display times/dates in correct time zone the API doesn’t. I think one fix is to use ‘time_created’ which is epoch timestamp and then use the timezone from beeminder settings. That worked for me in my script, before I migrated onto fitbit.

1 Like

Ah, interesting. Thanks for debugging it for me :slight_smile: – Sadly I think we have so few UP users that we’ve just never run into this before!

1 Like