Changing runits interacts poorly with road editor

Is runits per row in the road editor? Because that’s not shown, and the “5” and “0.71” in this screenshot aren’t using the same runits.

Also, changing runits from week to day and then back to week doesn’t result in the same number (5 -> 0.71 -> 4.97). I understand floating point rounding but this seems like a really large error, so I think it’s actually rounding to only the 2 displayed digits.

My graph (on looks screwy too, but I do still have 5 safe days (I just derailed) so I’m not sure what’s going on there.

EDIT: Also, how is runits supposed to interact with weekends off? With “days” I think it’s pretty obvious (which is why I wanted to change this, since I wasn’t quite sure what “weeks” meant with weekends off). But with “weeks”, is (or should) it be per calendar week (probably more intuitive to users) or implicitly converted to a daily rate by dividing by 7 (simpler implementation and probably more consistent with other runits settings)?

1 Like

This might be related to the state display refresh issue I’ve mentioned elsewhere. If you hard-refresh the page, do the rates in the “old” rows update to the new runit you specified?


Oh, you’re totally right. The rows all updated (to a nice fine-grained value, except for the last one which is still rounded to 2 decimal places) when I refreshed.


Yeah, it’s the latter and is confusing. Quoting the blog post:

You may find it helpful to switch your goal over to daily rate units if you’re using this feature. A goal set to 40hrs/week is equivalent to only 5.7 hours per day, so if you have your goal set to 40 hours/week, with weekends scheduled in this way, you only have to complete 28.5 hours each week to stay on track.

We originally had a warning about this in the UI but lost it in the redesign :frowning:

But probably the right answer is to force you to set runits=daily in order to use weekends-off.


That seems reasonable.

1 Like