Restarting goal: "start flat" always on?

Hi, has anyone else noticed that when you restart a goal, the “start flat” feature always seems to be active regardless of whether you tick the checkbox?

I seem to remember that it used to be that when you unchecked “start flat”, Beeminder would ask you for a current value just like it does when starting a new goal.

Now unchecking “start flat” does not seem to have any effect and my restarted goals always start flat. Might as well remove the checkbox then :slight_smile: Anybody else seeing the same thing?

1 Like

Well, since restarting a goal also doesn’t prompt you for what you want the rate to be (you have to hit the back button to figure it out) it is probably safer for it to give you the flat section. You can put in any rate you want and then retroratchet.

1 Like

Yes, I’ve also encountered this. I also agree with @drtall that it’s probably better to get rid of the button altogether. It’s better to set the rate from the road-dial after you’ve revived it.

1 Like

Sounds like it’s a straightup bug, but resetting/restarting is … awful already, and I’m under the impression that it’s relatively rare, and thus I keep letting the priority on all this stuff slide. I shall look at the actual numbers and see if reality backs me up on that.

1 Like

I’m pretty sure that we’re picking up the slope of the most recent road segment, which is almost right. Trouble is, because the goal has been inactive, the most recent road segment is the flatness of an absent goal. Probably need to look for the most recent non-zero slope.

What you can’t see is that the “start flat” checkbox is (probably) working perfectly. When checked, we inject a flat week before resuming the previous slope. i.e. giving you enough slack before the akrasia horizon so that you can change the slope. It’s invisible because we pick up the wrong slope.

I suspect that the only reason that more folks don’t shout about this is that we encourage (through defaults and bug-based-friction) long, practically unending goals. And because anyone who resumes goals regularly has probably discovered the workaround and stopped shouting…

Current workaround: change your slope to what you wanted, then retroratchet.