Anki Beeminder sync add-on broken?


#1

I recently downloaded the “Beeminder Sync” add-on for Anki. I have been happily using this add-on to update my Beeminder goal for Anki for the last week, but it suddenly is giving me an error message and failing to send data to Beeminder. I have emailed the add-on author, but I wanted to see if anyone here is also having issues.

The error message I’m getting is as follows:

Syncing failed:
’[Errno 11004] getaddrinfo failed’


Tech help beeminding OmniFocus
#2

The add-on works on my other computer… I wonder if using this on more than one computer is what’s causing me trouble.


#4

It looks like it got a network error when it tried to update Beeminder.


#5

I use it too, and since my add-on folder is synced via Dropbox, I probably used it from multiple Macs, though not regularly and not recently. Is it still broken? If @amesha is right, it should be a transient problem.

The add-on attempts* to store its (very minimal) config in the Anki collection object, so should get sync’d between machines via Ankiweb, just like your decks and study progress. Part of that config is the timestamp of the last sync, presumably to avoid reporting the same datapoint multiple times.

* ‘attempts’, because that’s currently broken for me; the collection doesn’t persist the updates, for reasons that I don’t yet understand. If config sync is working for you, you’ll see sensible comments in your Beeminder datapoints, like "anki update (+27)". If it’s broken, then the +number will be a total instead of an increment.

Tagging for @muflax


#6

I suppose it is a transient problem… I just tried re-installing the add-on this morning and it worked for me. Strange.


#7

I’m experiencing the same issue


beemind.me extra integrations
#8

I tried to investigate this, but I can’t find the addon on the anki site anymore.
Does anyone have the code already downloaded?


#9

It’s wildly unclear and I didn’t see any announcement, but there are remnants on GitHub


#10

@smokenflames have you tried these? Are you getting any error messages? Are you having trouble installing these?


beemind.me extra integrations
#11

@smokenflames, I was able to get philip’s fork to work today. The instructions aren’t the most user friendly. For instance, if you are on OS X, the script goes into ~/Documents/Anki/addons.

I spent 45 minutes debugging this script, and it was that I had mistyped my goal name in :slight_smile:

Let me know if you can’t get this to work for you, and I can help you debug it.