Beedroid cannot find my goals.

Beedroid running on my phone cannot find my goals.

I signed out to clear the cache and signed in again, it authenticated me, but gives me a screen telling me I have no goals created.

My goals are all visible via the web interface via my pc.

Anyone else have this problem?

1 Like

Apparently my device was warning me it was low on space, there was still several hundred MB free and everything else was working fine, just Beedroid refusing to sync my goals.

It would be nice if Beedroid told me this was what the problem was.

1 Like

Tagging for @saranli

1 Like

I have this problem as well. I just purchased a new phone for the specific and sole purpose of using tagtime and BM on it. I signed in, and BM says I don’t have any goals.

What’s going on? Help!

1 Like

i’m not an android user, so i don’t have any additional experience/ideas to contribute. but i did have this same problem one time and my problem/solution was the same as @insti’s - free phone memory approaching 0. cleared out some other apps and then everything worked fine.

so another vote for checking the memory if you’ve been playing with other new apps or added other stuff to the new phone.

1 Like

It’s a brand new phone. I basically have installed BM and Tagtime and one or two small apps. There’s 8GB on the phone. It should be able to handle that, right?

Or is there some other way I’m supposed to free up memory? My storage stats tell me I have 2GB free.

1 Like

@strickvl, have you submitted a bug report from with the app with diagnostics included? It may be that the problem will be obvious to us (ie, @saranli) if you do that.

Yep did that yesterday. (And resubmitted today in case it didn’t go through).


While we’re waiting for for @saranli to check out the diagnostics thing on android, have you tried:

  1. signing out and back in
  2. deleting and reinstalling the app

Thanks so much for the bug reporting and debugging help!

I have done both, on multiple occasions. No joy.

For posterity: We got to the bottom of this! Something to do with revoking access in which we didn’t handle properly. So, if that theory is right, there was some temporary problem which, in trying to reset everything to fully start from scratch, ironically became a permanent problem, until we manually intervened and reset the tokens.

Thanks so much for bearing with us, @strickvl!


Thank you. For the future, is there anything I should or shouldn’t do?

Just keep alerting us when you see anything fishy or confusing! We’ve pushed a bunch of updates to the Android app lately and it’s often 2 steps forward and 1 step back. So, yeah, bug reports hugely appreciated!


I seem to have done this same thing (sorry…) revoked access for beedroid because I wanted to revoke access to Zapier and I was just not paying enough attention. I signed out and signed in several times to see if it would help. Even uninstalled/reinstalled beedroid. Anyway, now my goals won’t show up on beedroid!

Thanks in advance.

1 Like