Bug: Can't fetch data from Sleep as Android

I am having trouble fetching data from Sleep as Android.

  1. On 1.01 I have created the sleep beeminder goal (through http://beeminder.com/sleep)
  2. after I have downloaded and bought the Sleep app. (with the same google acc that is linked to my Beeminder acc)
  3. On 2.01 I recorded my sleep with the Sleep app.
  4. tried to “Fetch New Data” several times, with no success
  5. created another slp goal (http://beeminder.com/yavitor/goals/slp)
  6. recorded 5 minutes of sleep data
  7. “Fetch New Data” - doesn’t work

recently tried this:

  1. removed Beeminder permissions from Google Account security settings ( I could see that Beeminder had access to
    my google basic profile info & e-mail address (since 1.01.2015.) )
  2. removed & reinstalled Beeminder app
  3. reapplied new permissions, signed in
  4. created yet another goal (slp1)
  5. created dummy data on Sleep
  6. Fetch Data → no luck
  7. noticed that on Google Account Permissions Beeminder is not listed (maybe there is a delay for it to reappear?)

I carefully read the related blog article

You authorize Beeminder (via Google) to read your Sleep as Android data

I have no idea how to give Beeminder authorization to access the Sleep app.

Help! :slight_smile:

1 Like

You might want to check again, I couldn’t get it to work either and then it just updated the goal, somehow.

Also you have to buy the sleep cloud plugin, I believe.

Bought the backup cloud add-on. (I believe it was not necessary, otherwise it would be clearly mentioned, mm? ) Will see if it helps

1 Like

Eep, I think we paid for things months ago when we first started thinking about Sleep as Android integration and forgot to mention it in the blog post! I’ll get @bee in here to confirm in the morning and update the blog post.

Up to this moment I can confirm that I have 4 datapoints that are all successfully stored in the SleepCloud.

I have set Google permissions for SleepCloud on the first visit of the http://sleep-cloud.appspot.com website.

I have removed the previous goal instances, except one, slp1.
The http://beeminder.com/yavitor/goals/slp1 goal is still not synced.

If later during the day the apps still wont sync I will try removing the goal and wash-rinse-repeat the process to see if that helps.

Cheers, @dreev!

1 Like

Yeah, this was our mistake, failed to mention in the post that the cloud backup add-on is necessary. I’ve just updated the post. We also need to find a way to mention that clearly on the landing / goal creation page.

@yavitor I dug into your sleep as android issues, and it is definitely a problem with the permissions granted from the google authorization, though it seems you have multiple times re-authorized :-\
Sorry for all the hassle. Can you re-try again, first removing Beeminder from the list of authorized apps in google security settings, (https://security.google.com/settings/security/permissions?pli=1 ) and then verify that Beeminder does re-appear in the list after re-authorizing?

Do you use multiple gmail accounts? I’m wondering if it could possibly be an issue with crossed wires on which email address is authorized on beeminder vs on sleep cloud… but I’m kind of grasping at straws with that.

Bethany

2 Likes