Beeminder Forum

Bug report: "Deleting [undefined] Are you sure?"

Am I sure? Sounds like Beeminder isn’t sure itself!

3 Likes

Thanks for the bug report! I can’t reproduce this so far. Is it something about the -9000? I tried that but it didn’t work (ie, it did work, ie, it didn’t work to reproduce the bug).

1 Like

I can’t reproduce it either, but it happened that one time ¯\_(ツ)_/¯

2 Likes

It happened again just now:

That pregnancy test must have been faulty :wink:

1 Like

I finally had this happen to me!

Theories:

  1. It happens when deleting a “RECOMMITTED” or “PESSIMISTIC PRESUMPTION” or something else Beeminder added automatically.
  2. It happens after you click “Load More Datapoints”
1 Like

I find it strange that you find this so hard to reproduce. In my experience, it happens whenever you add a datapoint, then immediately go and delete that same datapoint (without leaving or refreshing the page.)

It also seems pretty clear why it happens: the htmlForDatapoint function doesn’t include the data-canonical attribute on the .data-row div, so the drow.data("canonical") in bindDeleteDatapointButtons is undefined.

2 Likes

As is tradition: :wink:

On a more serious note:
I feel that between the false consensus effect, or worded specifically for software development…

…and to some extent good old confirmation bias there’s a perfectly reasonable explanation why there is a certain amount of “Betriebsblindheit” (German for “organisational blindness”) in those who create a product. This is something everyone who writes software or creates some product in some other way needs to look out for.

(to be clear, I am not saying @dreev got a monopoly on this. Absolutely not. I just used him as guinea pig for introducing the topic of how when you make a product it is hard to not fall victim to the aforementioned effects. I would know because I for sure have experienced them extensively. From both sides :wink:)

2 Likes

Ah! That’s a really clear bug report and yes, that does reproduce it for me too (@dreev!). Steps like that are really helpful, because it really makes it clear what exactly is going wrong. I don’t think anybody’s mentioned actual steps to reproduce it before. :slight_smile: Even just “here’s what I was doing when it happened” really helps; I’ve tried a few things before to get it to reproduce, but deleting a datapoint without having refreshed the page was just not something that occurred to me… though it might have done if someone had said “I entered a datapoint and then immediately went to delete it”, for example.

1 Like

Thanks zzq! Got that fixed up and deployed.

The top row doesn’t appropriately round or format the datapoint per your quantum/timeyness, but we’ve got that in the issue tracker.

1 Like