Beeminder Forum

I do not you want live notifications


#1

The forum keeps showing a question to enable browser notifications. I keep closing it, it comes back after a few days. Any way to permanently disable it?


#2

https://support.mozilla.org/en-US/kb/push-notifications-firefox#w_how-do-i-stop-firefox-asking-me-to-allow-notifications


#3

This shows up at the top of the page (as part of the content of the page), not as a browser popup


#4

Do you mean the little blue circle in the corner with a number in it? How does it show up?


#5

here it comes again…

pinging @dreev


#6

I have no answer for this but have a huge amount of trust in Discourse to make reasonable decisions. Why not just let it do browser notifications? They’re nice!


#7

I don’t need more notifications in my life :slight_smile:


#8

Yeah, I hear that! I think this case is super benign though. Like, if I understand it right (and, again, I’m mainly just trusting Discourse’s design decisions) it’s only going to show that notification if you have the forum open in a browser tab and someone is replying to you specifically. I’m guessing they decided to be pretty in-your-face about enabling that because they’re really sure that even the biggest anti-notification curmudgeon should at least see those. I’m just speculating though. There might be discussion threads on meta.discourse.org about the thinking behind it.


#9

Half of the issue is that the software is asking me a question, I am responding and a week later it is asking again. How many times do I need to reply? “No” means “no” :smiley:


#10

Apparently once for each time you have the forum open and someone replies to you specifically. So this reply will likely bring it up again evil grin.


#11

I have a hunch that it uses a cooke to set the negative/positive response and restarting Chrome seems to kill the cookie.


#12

You can probably create a greasemonkey/tampermonkey script to get rid of it every time it comes up.


#13

@apolyton Discourse got its own “Enable Notifications” toggle which you can turn off and then it will not bother you at all.
Simply allow the notifications on the browser side and then in Discourse’s preferences at “Live Notifications” make sure it looks like this:


Then you will not receive a single notification. This is in fact what I am doing for a while now and it works great. Discourse is happy and I am. And I guess you will be too!


#14

@phi - that’s the exact setting that he is getting messages asking if he wants to turn on! He already has that off.


#15

I’m not sure I follow. You don’t get that grey button in the screenshot unless you explicitly allow notifications on the browser side. Or to be more precise: You can not click that button and instead have a “Please turn on browser notifications” text there IIRC.
It’s like the Windows “Press the start button to shutdown the computer” thing. Sort of.

My understanding is that @apolyton keeps clicking the discourse blue box away which – if accepted – would trigger the browser asking him whether he wants to allow notifications. Since that didn’t happen they are not allowed. Which would be fine if his Chrome didn’t delete his cookie every once in a while apparently.

But it’s also late and I haven’t had coffee today so maybe I’m reading this all wrong.


#16

Oh, I see - you’re saying that the blue box is asking him to turn browser notifications on, and then if he turns those on he can turn Discourse notifications off.

If so, your proposed “solution” would make things much worse for him - yes, Discourse might stop bugging him, but then every other site would have notifications enabled!!!


#17

Every other site?
Normally browser notifications are per site, not globally.


#18

You can tell Firefox to never ask you if you want notifications for any site. That’s a global setting.

If you don’t do this, every single site that offers notifications will ask you if you want them.

But I guess he could turn them off globally, on for beeminder.com, and off for discourse - that might solve his problem.


#19

Thanks all for the suggestions. I’ll wait for the next prompt to enable it and then disable it from Chrome’s settings :slight_smile:


#20

This seems to have worked. Restarting Chrome seems to get the prompt to come back (I am also logged out of most services so I guess have some related Chrome setting enabled)
So I got the prompt from the forum, accepted it, then Chrome asked for confirmation and I blocked it. Now the forum settings look like this.
56