Inconsistent data from BeemiOS "Mindful Minutes"


#1

Has anyone else tried the “Mindful Minutes” auto data in the Beeminder iOS app? I’m seriously confused about what it’s doing. I’m getting mindful minutes data from three different apps and I cannot understand how BeemiOS is ending up with its totals.


#2

Yikes! As it turns out, my steps are no longer updating either. I keep trying to go to the iOS app and trigger a refresh, but no data points newer than July 4th have been imported into Beeminder.

I’ve confirmed that Beeminder still has permissions to access the relevant Health data AND I even went nuclear and reinstalled the Beeminder app. I’m at a loss! I won’t have an eep day until Saturday, but it’s sad to not have graphs updating.


#3

Is the deadline for the goal set to something other than midnight? That’s my first guess but it also wouldn’t explain all of the discrepancies.

And I believe the issue you’re seeing with the updates stopping is the same one a few others have reported, I should have a fix for that shortly.


#4

The deadline was 10 AM, until a couple of months ago when I switched it back to midnight. So I think you’re on to something there. It looks like the data points were being grouped with the 10 AM to 10 AM window starting the prior day.

When I reinstalled the Beeminder iOS app, the grouping changed to midnight to midnight. It looks like the iOS app is perhaps caching and not correctly refreshing the deadline for goals?

I’ll be on the lookout for the new version of the app and let you know if that fixes my problem.


#5

All fixed now.


#6

Sigh. Beeminder on iOS is doubling up my mindful minutes data points again; this time logging a session on both the actual day and for some reason on the prior day.

Tagging: @apb


#7

Thanks for reporting this, I’ll investigate. Is there any chance you recently changed time zones, or had your device’s time zone different than the one on your Beeminder account? That’s usually the prime suspect with mindful minutes these days but I’m working on making it robust to that situation.


#8

Actually yes – I went from US Eastern time to US Central time for several hours during a layover between flights on Christmas day. And it looks from my graphs like that might have been about when the problem started.

Does that seem consistent with what you’ve seen? That just a few hours in a slightly different time zone can trigger duplicates?


#9

Yep that (unfortunately) sounds right. Because of the way mindful minutes are reported with Apple Health (in sessions and divided into days by your deadline) changing the device’s time zone results in all that being recalculated and new datapoints being sent. It’s definitley not intentional or the smartest way to do it; I’m working on a fix but that’s good to know that this falls into that category. Let us know if you want any help cleaning up duplicate datapoints. Sorry for the hassle!


#10

Help with the duplicates would be great, thanks!


#11

Hi @apb – I’ve downloaded version 5.1 of BeemiOS and I tried hooking Mindful Minutes up to my meditation goal again. But sadly, the duplicate data struck once more:


#12

A solution for some people will be to set their meditation goal to aggregate as max so that only one of those datapoints counts (the highest of them). That should work for those of you who only meditate once per day.

If you’re on the Bee Plus or a higher subscription plan you can do this yourself by changing the goal type to custom and then setting the aggregation method. (All on the goal’s settings tab.)

If you’re just frustrated and this duplicates bug* is standing in your way, email support and we’ll set that for you beehind the scenes.

* it’s unclear to me whether it’s something that we can do anything about, in the case of travel and timezones and how Apple Health is reporting those datapoints…


#13

That’s a good idea, thank you.


#14

Sorry, I should have been clearer in the release notes about what was being fixed. 5.1 was expected to fix the spurious derails caused by overwriting old datapoints for the previous week. The duplicates are trickier and are partially being caused by a server-side-sort-of-bug where two datapoints that arrive at more or less the exact same time and with the same identifier are supposed to not be saved twice but they are. It’s not a travel/timezone issue and theoretically is totally solvable it’s just… taking a while :smiley: sorry!


#15

@apb I am having a problem with this as well. Despite having data logged in Apple Health I cannot get the app to synce. Pressing the “Sync with Health App” and “Sync Last 7 days” buttons just sit there with a spinner and never actually sync. Any ideas on what I can do?