There was a problem creating your goal / There was a problem deleting your goal

I tried creating a new goal after I had archived the old one. I used the same name, but it gave me an error and could not create the goal, so I assumed it was a naming conflict. I tried deleting the archived goal, but that also gave me an error saying could not delete the goal. What gives?

1 Like

That does sound puzzling - what’s the goal in question? You can email support@beeminder.com too if you don’t want to post it in the forum.

1 Like

The archived goal is this one: https://www.beeminder.com/haig/diet

I tried creating a new goal with that same name, and it gave me an error, so I tried deleted that archived goal above and it gave me an error again. I just created a new goal called ‘eating’ instead which worked fine.

1 Like

Ah that explains it - it looks like the goal isn’t actually deleted, only archived. Once it’s deleted you’ll be able to reuse the goal name. What are you seeing when you try to delete it?

Yes, but when I tried deleting it it gave me that second error, “problem deleting your goal”. I just left it as is and used a different name. Thanks though.

1 Like

Thanks again for the bug report! I’ve failed to reproduce this. Could you try again to delete the goal and tell us the exact error?

Sure. I’m using Chrome ver 54.0.2840.71 on OS X ver 10.12.1. Here are the steps I take:

  1. Go to my goals page.
  2. Click on archived goals.
  3. Click on the trashcan icon below the ‘Diet’ goal I want to delete.
  4. Receive error

Here’s the screenshot:

3 Likes