Beeminder App v4 for iPhone

Hello, I updated the App on my iPhone 4s. Now the Apps works one or two times, then it hangs up. To get it back working I sign out and sign in and then it works again.



[admin update: tagging for @apb]

1 Like

Not sure if this is related, but a friend of mine tried to sign up today on the iphone. She opened the iphone app, clicked “Facebook login” and got taken to a page saying her credentials were invalid. Then she went back into the Beeminder app and it showed “Log out” from Facebook but she wasn’t actually logged into Beeminder.

1 Like

@apb I’m experiencing the same sort of lock-up on my iPhone 5s. The old ‘reload beeswax’ button was handy for these occurrences.

Right now I’m staring at a blank goal gallery, which periodically refreshes and updates the ‘last updated’ time at the top. Sometimes this view features the I’m-working spinner, this time it’s blank.

Yesterday evening, it only showed a small subset of goals in my gallery and I had to log out and back in to force a reload of the goals.

This morning, it still had a complete set, but seemed fixated on yesterday’s sort order, so my gmailzero beemergency was down at the bottom of the list, though it was red and correctly identified as an emergency.

I killed and relaunched the app, which has resulted in the currently blank gallery. I did this while at home on the wifi, so it shouldn’t be a network issue. (Though I suspect that the app doesn’t deal well with flaky network, which I think is what resulted in my partial gallery earlier in the day.)

Aside: my most common use case for the app is to quickly check on the status of my goals, most of which get updated by other means. My experience with the previous version of the app was that it was usually unhelpfully out of date. My experience with this version is the opposite; it teases me by saying that it’s refreshed less than a minute ago and then takes an age to display my goals.

Apart from the teething issues, this looks like a solid improvement. Thanks!

1 Like

Same solution (log out-in) on an iPhone 5.
And same experience with a plot being blank before sometime before the whole Goal screen below the header was blank.

1 Like

Sorry for the BeemiOS troubles, iPhone people! As a possible workaround till we figure it out, does hitting the settings gear icon snap it back to full consciousness? (Not at all sure that will work but gathering more evidence for @apb.) Thanks so much for the bug reports!

PS: List of candidate things for expedited release of v4.1…

  1. Blank screen / missing goals bug
  2. Facebook login problem
  3. Put back “re-fetch beeswax”
  4. Copy on initial screen saying to first create a goal at
1 Like

I have been having a lot of issues as well. The blank screen bug is the biggest thing. What happened to the ability to allow for manual data entry even on synced goals? I really really needed this ability sometimes when I happen to do things outside of the normal methods (Runkeeper, Pomodoros on my calendar etc) but I still want to log them. Is there a workaround for this right now?


Oh man, there’s an equally, though less publicly, vocal group clamoring for us to close loopholes like that. (: But there is still the workaround of emailing data to with username/goalslug in the subject and the body of the email using the data format like in the advanced data entry.

PS: Thanks to the responses from my beemail straw poll we have a better sense of this blank screen bug, though still haven’t figured out how to reproduce it. So please keep the bug reports (with all the details you can think of) coming! And of course thanks to @apb for jumping all over it this weekend. We’ll keep posting updates as we figure it out.

PPS: If anyone can confirm whether the gear icon workaround does or doesn’t work for them, that would still be helpful to hear.

New version imminently available!

@apb says: “app is in review, should be updated today”


I also used to use this, but I think I like that it now works the same as the website. Note that some autodata sources will overwrite your manual entries, so it can be tricky to mix multiple data-entry methods on a single goal.

1 Like

4.1 is now in the store (you may have to search directly and it may take a bit to propagate). I’m hopeful it will fix the disappearing goals issue. If you’ve been seeing that issue let me know here in the forum if the update resolves it!


I personally haven’t seen a blank screen since I updated to 4.1.

What I do still get sometimes is a stuck update spinner. So far, I’ve been able to force the app to come back to its senses by [killing it]( “Mini-HOWTO: double-click on the home button, flick the app upward. Not a necessary habit, but sometimes fixes misbehaving apps…”) and relaunching.

Aside: this morning, the update spinner came on screen, and I experienced the psychological oh-no! moment before the app updated my goal gallery as intended.

1 Like

Update: Version 4.1 still has the occasional hanging spinner bug. Workaround is to hit the settings gear icon. Next version will have an actual fix.

Version 4.1 does fix the disappearing goals bug but some people are having to sign out and back in, or delete and reinstall the app, else they sometimes still experience it. We haven’t figured out how to eliminate the need for that yet…

Keep sending bug reports; hugely appreciated!