Beeminder Forum

Heisenbug report: Odometer banner read "today's weight is required"

I was creating a flat-forever goal for a book today, à la @shanaqui (before discovering that you can’t do that and then finding the workaround) and left “Today’s value” blank, assuming it would autofill 0. It didn’t, which is fine, but the banner confusingly read “Today’s weight is required”.

Unfortunately, I haven’t been able to replicate it; fortunately, I had the foresight to take a screenshot:

You can see the commit-per-day section is there, so I definitely didn’t select the weightloss goaltype by accident. Once I finish making this goal properly, I’ll go see if I can find some way to replicate.

2 Likes

I’ve tried a bunch of different permutations and can’t get it to happen again :frowning:

1 Like

ah, thank you so much for reporting that! it’s a known issue [internal link] with our local storage getting corrupted. hearing about additional encounters with that bug is very valuable so please don’t feel like “oh the workerbees already know about this, no point bugging them”!

Excerpt from the internal ticket (gissue, as we call them)

Summary: When you load another Beeminder page during goal creation, the localstorage gets hosed.

Happens a lot, in all browsers. Severity high. NICKY 2021: Doesn’t happen every day by any means, nor even every week, but steadily. Existing users take it in stride and usually figure things out; new users tend to be inclined to give up as the whole site seems broken if they can’t even make a goal.

Replicata

  1. Create a new goal, click through until the naming screen
  2. Command-click on username to open existing goal list in a new tab
  3. Continue to Choose Pledge page
  4. Click “Finish”

Expectata

Goal should be created.

Resultata

“There was a problem creating your goal.”

Nota Nebulosa

This happens to me (dreev) with some regularity, whenever I go clicking around to other goals for comparison or something while creating a new goal.

In terms of proximate cause, it seems the browser sends something malformed to the API which returns a 422 error.

1 Like

Ah ha! I was clicking around to other beeminder pages (possibly importantly, mostly the forum iirc?)—I tried to replicate loading another page while doing that but I must not have gotten the timing right. That sounds well gnarly; good luck!

1 Like